BETA

21st October 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [21/10/19 04:44 PM] with 'Major Outage'

Issue has been resolved at [21/10/19 04:54 PM]