BETA

21st October 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [21/10/19 02:55 PM] with 'Major Outage'

Issue has been resolved at [21/10/19 03:14 PM]