BETA

21st October 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [21/10/19 01:24 PM] with 'Partial Outage'

Issue has been resolved at [21/10/19 01:34 PM]