BETA

30th December 2018

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [30/12/18 12:13 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [30/12/18 12:23 PM]