BETA

20th October 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [20/10/19 12:44 PM] with 'Major Outage'

Issue has been resolved at [20/10/19 12:54 PM]