BETA

20th October 2019

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [20/10/19 05:34 AM] with 'Partial Outage'

Issue has been resolved at [20/10/19 05:54 AM]