BETA

19th October 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [19/10/19 01:24 PM] with 'Partial Outage'

Issue has been resolved at [19/10/19 02:14 PM]