BETA

9th May 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [09/05/17 01:03 PM] with 'Partial Outage'

Issue has been resolved at [09/05/17 01:04 PM]