BETA

18th October 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [18/10/19 12:55 PM] with 'Partial Outage'

Issue has been resolved at [18/10/19 01:44 PM]