BETA

18th October 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [18/10/19 01:34 AM] with 'Major Outage'

Issue has been resolved at [18/10/19 01:35 AM]