BETA

17th October 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [17/10/19 02:44 PM] with 'Major Outage'

Issue has been resolved at [17/10/19 02:45 PM]