BETA

17th October 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [17/10/19 01:44 PM] with 'Partial Outage'

Issue has been resolved at [17/10/19 01:45 PM]