BETA

27th December 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [27/12/18 05:46 PM] with 'Major Outage'

Issue has been resolved at [27/12/18 05:47 PM]