BETA

8th May 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [08/05/17 04:54 PM] with 'Partial Outage'

Issue has been resolved at [08/05/17 04:55 PM]