BETA

26th December 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [26/12/18 01:28 PM] with 'Partial Outage'

Issue has been resolved at [26/12/18 01:33 PM]