BETA

26th December 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [25/12/18 08:27 PM] with 'Major Outage'

Issue has been resolved at [25/12/18 08:28 PM]