BETA

24th December 2018

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [24/12/18 01:31 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [24/12/18 01:32 PM]