BETA

24th December 2018

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [24/12/18 12:41 PM] with 'Partial Outage'

Issue has been resolved at [24/12/18 12:44 PM]