BETA

8th May 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [08/05/17 11:20 AM] with 'Partial Outage'

Issue has been resolved at [08/05/17 11:22 AM]