BETA

16th October 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [16/10/19 12:44 PM] with 'Partial Outage'

Issue has been resolved at [16/10/19 12:54 PM]