BETA

15th October 2019

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [15/10/19 03:34 PM] with 'Partial Outage'

Issue has been resolved at [15/10/19 03:44 PM]