BETA

22nd December 2018

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [22/12/18 04:02 PM] with 'Partial Outage'

Issue has been resolved at [22/12/18 04:09 PM]