BETA

15th October 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [15/10/19 11:44 AM] with 'Partial Outage'

Issue has been resolved at [15/10/19 11:45 AM]