BETA

15th October 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [15/10/19 11:34 AM] with 'Major Outage'

Issue has been resolved at [15/10/19 11:54 AM]