BETA

15th October 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [15/10/19 10:24 AM] with 'Partial Outage'

Issue has been resolved at [15/10/19 10:34 AM]