BETA

24th July 2016

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [24/07/16 12:44 AM] with 'Partial Outage'

Issue has been resolved at [24/07/16 12:45 AM]