BETA

22nd December 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [22/12/18 03:02 PM] with 'Partial Outage'

Issue has been resolved at [22/12/18 03:05 PM]