BETA

22nd December 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [22/12/18 03:02 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [22/12/18 03:09 PM]