BETA

14th October 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [14/10/19 03:04 PM] with 'Partial Outage'

Issue has been resolved at [14/10/19 03:14 PM]