BETA

14th October 2019

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [14/10/19 11:54 AM] with 'Partial Outage'

Issue has been resolved at [14/10/19 12:14 PM]