BETA

14th October 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [14/10/19 11:44 AM] with 'Major Outage'

Issue has been resolved at [14/10/19 12:44 PM]