BETA

22nd December 2018

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [22/12/18 01:14 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [22/12/18 01:20 PM]