BETA

13th October 2019

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [13/10/19 04:24 PM] with 'Partial Outage'

Issue has been resolved at [13/10/19 04:34 PM]