BETA

13th October 2019

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [13/10/19 01:44 PM] with 'Partial Outage'

Issue has been resolved at [13/10/19 01:45 PM]