BETA

7th May 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [07/05/17 05:23 AM] with 'Partial Outage'

Issue has been resolved at [07/05/17 05:24 AM]