BETA

13th October 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [13/10/19 12:24 PM] with 'Major Outage'

Issue has been resolved at [13/10/19 12:34 PM]