BETA

20th December 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [20/12/18 01:21 PM] with 'Partial Outage'

Issue has been resolved at [20/12/18 01:26 PM]