BETA

20th December 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [19/12/18 09:16 PM] with 'Partial Outage'

Issue has been resolved at [19/12/18 09:18 PM]