BETA

13th October 2019

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [13/10/19 09:34 AM] with 'Partial Outage'

Issue has been resolved at [13/10/19 09:44 AM]