BETA

13th October 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [13/10/19 09:14 AM] with 'Major Outage'

Issue has been resolved at [13/10/19 06:54 PM]