BETA

13th October 2019

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [13/10/19 09:05 AM] with 'Partial Outage'

Issue has been resolved at [13/10/19 06:54 PM]