BETA

13th October 2019

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [13/10/19 09:04 AM] with 'Major Outage'

Issue has been resolved at [13/10/19 06:54 PM]