BETA

19th December 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [19/12/18 06:27 PM] with 'Partial Outage'

Issue has been resolved at [19/12/18 06:29 PM]