BETA

19th December 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [19/12/18 05:32 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [19/12/18 05:51 PM]