BETA

13th October 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [13/10/19 02:04 AM] with 'Major Outage'

Issue has been resolved at [13/10/19 02:14 AM]