BETA

12th October 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [12/10/19 02:44 PM] with 'Partial Outage'

Issue has been resolved at [12/10/19 02:54 PM]