BETA

12th October 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [12/10/19 10:24 AM] with 'Partial Outage'

Issue has been resolved at [12/10/19 10:54 AM]