BETA

19th December 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [19/12/18 03:45 PM] with 'Major Outage'

Issue has been resolved at [19/12/18 04:09 PM]