BETA

12th October 2019

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [12/10/19 12:34 AM] with 'Partial Outage'

Issue has been resolved at [12/10/19 01:04 AM]