BETA

11th October 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [11/10/19 10:55 PM] with 'Partial Outage'

Issue has been resolved at [11/10/19 11:04 PM]